Jump to content


Photo

Database Won't Install


  • Please log in to reply
9 replies to this topic

#1 ukhost4u

ukhost4u

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 24 August 2004 - 09:00 PM

Hello,

When I try to install rvadmin I get the following error:

Updating rvskin database...
=============================
DBI connect('rvadmin_news:localhost','rvadmin_public',...) failed: Access denied for user: 'rvadmin_public@localhost' (Using password: YES) at /root/rvadmin/real_auto_rvskin.pl line 38

Database connection failed, You need to create it manually using database information below:

#################


This is a new server and I can't see what the issue is as it works on all my other boxes.

Can anyone help?

Paul Hughes

#2 pairote

pairote

    Administrator

  • Admin
  • PipPipPip
  • 4,351 posts

Posted 24 August 2004 - 09:25 PM

Please check 2 things:
1. Do you have configure this server to use remote MySQL?
You can check in https://SERVER_IP:20...remotemysqlhost
2. Go to WHm / MySQL / phpMyAdmin, and select 'mysql' database in the database list.
Click SQL query and place this in the textarea box.

SELECT * FROM db WHERE user like 'rvadmin_%'

Delete all records. And run installer again.

If none of which is work, please email me root password, and IP. I will take a look.

#3 ukhost4u

ukhost4u

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 24 August 2004 - 09:34 PM

First issue: MySQL is setup as Current MySQL: localhost
Second issue: There is no such file.

Please advise if this helps.

Paul Hughes

#4 takap

takap

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 05 October 2004 - 04:52 PM

I had the same issue while re-installing rvskin.
After I have checked the installation process for several hours, finally I found the cause.

Before you try to re-install rvskin, try to uninstall it by following the instruction:
http://www.rvskin.co...page=public/faq

After that, you have to remove rvskin related entries on your mysql database:
"rvadmin_news" database, "rvadmin" in the "user" table of "mysql", some records held by rvadmin_news in the "db" table of "mysql".

If you are not familier with mysql console, just use phpmyadmin from your WHM. If you get access denied message when you open phpmyadmin, check the file /root/.my.cnf.
It will be something like this:

[client]
user="root"
pass="yourdbpass"

If you see any quotation(") just remove them, and it will be:

[client]
user=root
pass=yordbpass

after saving the file, open phpmyadmin again. You will be able to access your database.

to pairote:
I am happy with rvskin and thank you for the great product. If I am missing something please correct it.

#5 pairote

pairote

    Administrator

  • Admin
  • PipPipPip
  • 4,351 posts

Posted 05 October 2004 - 07:02 PM

All correct. smile.gif

I think I will create uninstall script to clean all db stuffs.

#6 scooterharris

scooterharris

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 20 October 2004 - 07:08 AM

I'm having the same problem on this, are you able to tell me the fix for this?

Scooter

#7 Aric

Aric

    Advanced Member

  • Members
  • PipPipPip
  • 84 posts

Posted 21 October 2004 - 04:50 AM

Takap listed the fix above. Just follow those directions and remove the quotes from your my.cnf file.
Want to learn more about cPanel?
Try my book on the subject (available in both electronic and print versions):
cPanel: User's Guide and Tutorial
WHM book:
Web Host Manager Administration Guide

#8 ayksolutions

ayksolutions

    Member

  • Members
  • PipPip
  • 12 posts

Posted 17 November 2005 - 11:29 AM

Hmm... I am also having that issue. I checked and I do have mysql remote access setup and enabled. I aslo uninstalled and re-installed with no luck.

Any other ideas?

#9 pairote

pairote

    Administrator

  • Admin
  • PipPipPip
  • 4,351 posts

Posted 17 November 2005 - 02:06 PM

ayksolutions, I fixed it on your server. Please check it.

#10 ayksolutions

ayksolutions

    Member

  • Members
  • PipPip
  • 12 posts

Posted 18 November 2005 - 06:25 AM

Hey, yeah, thanks it works.