Jump to content


Photo

suhosin


  • Please log in to reply
2 replies to this topic

#1 Host2Host

Host2Host

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 29 July 2008 - 11:25 AM

Hi,

I just started receiving alerts over last 2 days from suhosin.

suhosin[8773]: ALERT - configured request variable name length limit exceeded - dropped variable '/var/cpanel/rvglobalsoft/rvsitebuilder/scripts/RVSeagullMod-1_0_1_tgz' (attacker 'REMOTE_ADDR not set', file 'unknown')

Any suggestions?

Cheers.

#2 Sergio

Sergio

    Advanced Member

  • Members
  • PipPipPip
  • 281 posts

Posted 29 July 2008 - 12:20 PM

You will need to increase that variable in suhosin.

I have set the following suhosin options in php.ini that have helped me to fix the suhosin errors:
CODE
[suhosin]
; For translation manager to handle more inputs
suhosin.post.max_vars = 2000
suhosin.request.max_vars = 2000

; For URL handling
suhosin.request.max_totalname_length = 300
suhosin.request.max_varname_length = 300
suhosin.get.max_varname_length = 300
suhosin.get.max_name_length = 300


Increase the value as you need it. And don't forget to restart apache.

Regards,
Sergio
We do custom RVSB templates,examples at:
www.prueba.biz/motorcycle
www.a-la-venta.com/volvo

#3 Host2Host

Host2Host

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 10 August 2008 - 06:58 AM

That did the trick!

Added to php.ini

Cheers wink.gif