Jump to content


Member Since 03 Dec 2012
Offline Last Active Mar 11 2014 01:45 PM

Topics I've Started

Fatal Error

09 March 2014 - 10:08 AM

Hi I am getting this message & my site is down.I used Rvsitebuilder to build my site which was part of my package through VentraIP my provider. I have tried their tech help & they did a RVsitebuilder reinstall but the problem wasn't fixed. They asked me to contact you guys... The error is:

Fatal error: Cannot make static method SGL_FrontController::run() non static in class RVSWebInit in /home/grantluc/public_html/rvsStaticWeb.php on line 39

I had problems with my site a few months ago & when my provider couldnt fix it was finally remedied through RVsitebuilder tech help. You guys have been much more help than my provider. VentraIP were very good a couple of years ago but now just seem to leave things to their customers to fix by themselves. I havent done anything to my site since my last problem & have several months of problem free operation with my numbers getting slowly back to where they were before the initial crash. I am not sure what has happened here unless there has been a recent RVsitebuilder upgrade?? Looks like something is still screwed up. Can someone give me any idea of what the problem may be? The site that is down is my main site & this has been 3 days now & my provider has given up so I am getting concerned.
Thanks in advance.

Cannot Restore Backup

13 August 2013 - 03:36 PM

I'm using RVsitebuilder through my CPanel. It is provided as part of my hosing package from my IP (VentraIP). My site went down a couple of weeks ago. It has been 35 "E tickets" and days of research later & as this cannot be resolved through my provider I am wondering if it is something someone here at RV sitebuilder can solve. All I want to do is restore my site with one of my previous 2 backups as they are my most up to date versions of my site. This doesn't seem to be possible. My most recent 2 backups were full backups and not just home directory backups. This means I needed to get the site restored by my provider as this (I am told) cannot be done through Cpanel. Initially the problem was an error message "connection reset error"....my provider restored the site by changing DNS settings. The site was fine for a week or 2 then went down again with "internal server problems". they replied that they were getting the error message "Fatal error: require_once() [function.require]: Failed opening required '/home/grantluc/.rvsitebuilder/seagull/lib/SGL/FrontController.php' (include_path='.:/usr/lib/php') in /home/grantluc/public_html/rvscommonfunc.php on line 228". I was told to re-publish my site. I logged into Rvsitebuilder & it told me my project was missing??? I then ticked the restore box for my project & it restored but tells me it is back to feb 2012. OK now a bigger problem than I thought. That is a really old version & the link to my blog gives an error message Cannot write to directory /home/grantluc/.rvsitebuilder/websitepublish/c0c33375cac40a49b7478a1342308433/var/cache/templates_c. Please check the permissions. I Checked google & could not find my site anymore???? Not even cached. I had to search for my contact page on bing & look at a cached page. Everything was fine on the 13/07/13 when the snapshot was taken. I did this using my last full backup which resulted in the correct data but my blog was missing. I sent in another call for help & was told to upload my last full backup. It was in a .tar.gz format. I uploaded & they restored it & it was fine except my blog entries were missing. The blog serendipity skeleton structure loaded but I don't get any of my entries.... They then indicated that somehow my site was duplicated on 2 servers (goodness knows how they managed to do this to me) & they would correct this.& changed my DNS settings again. They removed one version of my site. I checked and everything was back to my 18 month old site including my blog. My provider insisted that the most recent backup must have that data on it & I insisted it couldn't as they had restored it correctly (except for the blog) earlier so what was being seen must be some form of pathing problem. I learned how to unzip my full and partial backups & find the homedir.tar file within(.tar zipped inside.gz was a headache) to prove that the data was in them that I had suspected. The files seemed fine except the backup files pathing was specifically to /home2 directory not /home as the old version of my site was. My provider assured me that they had something called a "Symlink" (whatever that is)/home2/grantluc -> /home/grantluc/ which fixed pathing problems like this. I then uploaded my blog .sql backups to my provider & my blog was restored to its most recent form. It has now been about 20 more "Etickets" later & my site is still 18 months old & cannot restore to what it was last month. I researched & found out about the rvsdbbackup.sql, informed my provider & was advised to go into phpmyadmin, export & back up the default localhost file & then click the import button & select the rvsdbbackup.sql database & select go. It went for a couple of seconds before I got the following screen & it stopped
SQL query:
REPLACE INTO `rvs_category` ( `rvs_category_id` , `category_name` , `category_sh_name` )
'22', 'Plain Template', 'pl'
MySQL said: Documentation
#1046 - No database selected
AARGH!!! I then tried an rvsdbbackup.sql from 3 months earlier & got the same error.
So I currently have multiple full backups that cannot seem to work as they will not overwrite what is currently on my site, a provider that doesn't seem to be able to help, database backups that throw up error messages... what now??? Can I just cut & paste the 2 main culprit pages from backups to my current public_html directory? One page is currently completely missing and my home page was seriously changed. I have a .php file of the missing web-page that perhaps could be somehow cut & pasted back into the old site, but I cannot seem to find my "home.php" in my old backups. It exists in the current public_html (but actually 18 month old version)directory of my site. If I could find where this file actually is stored in old backup files (pre-version 5) I could more easily determine what was in the backup as my home page changed more than any other. I have searched numerous index.php files & they just have code in them & not any of my text. Any help or suggestions would be appreciated.