Jump to content


Photo

New Server


  • This topic is locked This topic is locked
5 replies to this topic

#1 4uh

4uh

    Advanced Member

  • Members
  • PipPipPip
  • 80 posts

Posted 13 November 2009 - 08:46 PM

Just installing rvsitebuilder on a new server...

I get the errors about cpanel php settings...

QUOTE
RVSiteBuilder recommend PHP maximum amount of memory a script may consume 164 or above. Edit /usr/local/cpanel/3rdparty/etc/php.ini and change "memory_limit=128M", and restart cPanel service (/usr/local/cpanel/startup).


I have done this - but every time I restart cpanel it automatically reverts back to the old setting of 128M. This is forced by a config somewhere in cpanel. In the "Tweak Settings" there is an option to change the cpanel php max execution time but not the memory limit.

I cant get past the Pre-Installation Check page - there is no option to continue.



#2 pairote

pairote

    Administrator

  • Admin
  • PipPipPip
  • 4,351 posts

Posted 16 November 2009 - 12:35 PM

Please contact your provider to SSH to the server as root and run

perl /var/cpanel/rvglobalsoft/rvsitebuilder/panelmenus/cpanel/scripts/autofixphpini.pl

and restart cPanel service with this command

/usr/local/cpanel/startup

Then edit or create /scripts/postupcp to execute autofixphpini.pl every upcp run (no need to restart cPanel on postupcp, as upcp will do it automatically.). Please find example of /scripts/postupcp at http://forums.rvskin...?showtopic=2760 .

#3 factor

factor

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 16 November 2009 - 06:06 PM

root@raven [~]# perl /var/cpanel/rvglobalsoft/rvsitebuilder/panelmenus/cpanel/sc
ripts/autofixphpini.pl
Can't open perl script "/var/cpanel/rvglobalsoft/rvsitebuilder/panelmenus/cpanel
/scripts/autofixphpini.pl": No existe el fichero o el directorio

#4 factor

factor

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 16 November 2009 - 06:13 PM

there's no such dir because rvsitebuilder isn't even installed, we can't go past the first step

#5 pairote

pairote

    Administrator

  • Admin
  • PipPipPip
  • 4,351 posts

Posted 16 November 2009 - 06:23 PM

Edit /usr/local/cpanel/3rdparty/etc/php.ini but do not restart cPanel and try again.

#6 Bovaatrobia

Bovaatrobia

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 15 March 2011 - 05:36 PM

this new server has 16 processing cores and 16GB of memory. there really arent any traffic-based slowdowns any more. We will keep looking for any potential bottlenecks, but the server is good to go. Eric
Lose weight with acai berry diet